CVE-2019-13113

NameCVE-2019-13113
DescriptionExiv2 through 0.27.1 allows an attacker to cause a denial of service (crash due to assertion failure) via an invalid data location in a CRW image file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)jessie, jessie (lts)0.24-4.1+deb8u7vulnerable
stretch (security)0.25-3.1+deb9u3vulnerable
stretch (lts), stretch0.25-3.1+deb9u4vulnerable
buster0.25-4+deb10u2fixed
buster (security)0.25-4+deb10u4fixed
bullseye0.27.3-3+deb11u2fixed
bullseye (security)0.27.3-3+deb11u1fixed
sid, trixie, bookworm0.27.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2sourcebuster(not affected)
exiv2source(unstable)0.27.2-6unimportant

Notes

[buster] - exiv2 <not-affected> (Vulnerable code introduced later)
https://github.com/Exiv2/exiv2/commit/6212806b7637be683a56c769a8d905153996d933
https://github.com/Exiv2/exiv2/commit/ccde30afa8ca787a3fe17388a15977f107a53b72
https://github.com/Exiv2/exiv2/issues/841
Negligible security impact

Search for package or bug name: Reporting problems