CVE-2019-13308

NameCVE-2019-13308
DescriptionImageMagick 7.0.8-50 Q16 has a heap-based buffer overflow in MagickCor ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2366-1, DSA-4712-1, ELA-279-1
Debian Bugs931447

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie, jessie (lts)8:6.8.9.9-5+deb8u22fixed
stretch8:6.9.7.4+dfsg-11+deb9u8vulnerable
stretch (security)8:6.9.7.4+dfsg-11+deb9u11fixed
buster, buster (security)8:6.9.10.23+dfsg-2.1+deb10u1fixed
bullseye8:6.9.11.24+dfsg-1fixed
sid8:6.9.11.57+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.11.24+dfsg-1low931447
imagemagicksourcebuster8:6.9.10.23+dfsg-2.1+deb10u1DSA-4712-1
imagemagicksourcejessie8:6.8.9.9-5+deb8u21ELA-279-1
imagemagicksourcestretch8:6.9.7.4+dfsg-11+deb9u10DLA-2366-1
imagemagicksourcewheezy(unfixed)end-of-life

Notes

[jessie] - imagemagick <postponed> (minor, wait for upstream to clear patch-related questions)
https://github.com/ImageMagick/ImageMagick/issues/1595
https://github.com/ImageMagick/ImageMagick6/commit/19651f3db63fa1511ed83a348c4c82fa553f8d01

Search for package or bug name: Reporting problems