CVE-2019-15167

NameCVE-2019-15167
DescriptionThe VRRP parser in tcpdump before 4.9.3 has a buffer over-read in print-vrrp.c:vrrp_print() for VRRP version 3, a different vulnerability than CVE-2018-14463.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)jessie, jessie (lts)4.9.3-1~deb8u2fixed
stretch (security), stretch (lts), stretch4.9.3-1~deb9u2fixed
buster4.9.3-1~deb10u2fixed
buster (security)4.9.3-1~deb10u1fixed
bullseye4.99.0-2+deb11u1fixed
bookworm4.99.3-1fixed
sid, trixie4.99.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsourcejessie4.9.3-1~deb8u2
tcpdumpsourcestretch4.9.3-1~deb9u2
tcpdumpsourcebuster4.9.3-1~deb10u1
tcpdumpsource(unstable)4.9.3-1

Notes

Fixed by: https://github.com/the-tcpdump-group/tcpdump/commit/a152aebfd1114376ba266ed30416be596ef9d806 (tcpdump-4.9.3)

Search for package or bug name: Reporting problems