CVE-2019-18679

NameCVE-2019-18679
DescriptionAn issue was discovered in Squid 2.x, 3.x, and 4.x through 4.8. Due to ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2028-1, DLA-2278-1, DSA-4682-1, ELA-271-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, buster (security)4.6-1+deb10u4fixed
sid, bullseye4.13-1fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u2fixed
stretch3.5.23-5+deb9u1vulnerable
stretch (security)3.5.23-5+deb9u5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)4.9-1
squidsourcebuster4.6-1+deb10u2DSA-4682-1
squidsourcewheezy(unfixed)end-of-life
squid3source(unstable)(unfixed)
squid3sourcejessie3.5.23-5+deb8u1ELA-271-1
squid3sourcestretch3.5.23-5+deb9u2DLA-2278-1
squid3sourcewheezy(unfixed)end-of-life

Notes

Squid 4: http://www.squid-cache.org/Versions/v4/changesets/squid-4-6f2841090dffbec1a2b2417e18bb3dc71d62dd2e.patch
http://www.squid-cache.org/Advisories/SQUID-2019_11.txt

Search for package or bug name: Reporting problems