CVE-2019-18860

NameCVE-2019-18860
DescriptionSquid before 4.9, when certain web browsers are used, mishandles HTML ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2278-1, DSA-4732-1, ELA-271-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, buster (security)4.6-1+deb10u4fixed
sid, bullseye4.13-1fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u2fixed
stretch3.5.23-5+deb9u1vulnerable
stretch (security)3.5.23-5+deb9u5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)4.9-1low
squidsourcebuster4.6-1+deb10u3DSA-4732-1
squidsourcewheezy(unfixed)end-of-life
squid3source(unstable)(unfixed)
squid3sourcejessie3.5.23-5+deb8u1ELA-271-1
squid3sourcestretch3.5.23-5+deb9u2DLA-2278-1
squid3sourcewheezy(unfixed)end-of-life

Notes

https://github.com/squid-cache/squid/pull/504
https://github.com/squid-cache/squid/commit/5cc4b155cee1a4968109737f6eba2ef29d51034d (SQUID_5_0_1)
https://github.com/squid-cache/squid/commit/5a90b4ce64c346ba7f317a278ba601091d9de076 (SQUID_4_9)

Search for package or bug name: Reporting problems