CVE-2019-19242

NameCVE-2019-19242
DescriptionSQLite 3.30.1 mishandles pExpr->y.pTab, as demonstrated by the TK_C ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)jessie, jessie (lts)3.8.7.1-1+deb8u6fixed
stretch3.16.2-5+deb9u1fixed
stretch (security)3.16.2-5+deb9u3fixed
buster3.27.2-3+deb10u1fixed
bullseye3.34.0-1fixed
sid3.34.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3source(unstable)3.30.1+fossil191229-1
sqlite3sourcebuster(not affected)
sqlite3sourcejessie(not affected)
sqlite3sourcestretch(not affected)
sqlite3sourcewheezy(not affected)

Notes

[buster] - sqlite3 <not-affected> (Vulnerable code not present)
[stretch] - sqlite3 <not-affected> (Vulnerable code introduced later)
[jessie] - sqlite3 <not-affected> (Vulnerable code not present)
https://github.com/sqlite/sqlite/commit/57f7ece78410a8aae86aa4625fb7556897db384c
[wheezy] - sqlite3 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems