CVE-2019-19645

NameCVE-2019-19645
Descriptionalter.c in SQLite through 3.30.1 allows attackers to trigger infinite ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs946612

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)jessie, jessie (lts)3.8.7.1-1+deb8u6vulnerable
stretch3.16.2-5+deb9u1fixed
stretch (security)3.16.2-5+deb9u3fixed
buster3.27.2-3+deb10u1vulnerable
sid, bullseye3.34.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3source(unstable)3.30.1+fossil191229-1946612
sqlite3sourcestretch(not affected)
sqlite3sourcewheezy(not affected)

Notes

[buster] - sqlite3 <ignored> (Minor issue, too intrusive to backport)
[stretch] - sqlite3 <not-affected> (Vulnerable code introduced later)
[jessie] - sqlite3 <no-dsa> (Minor issue)
https://github.com/sqlite/sqlite/commit/38096961c7cd109110ac21d3ed7dad7e0cb0ae06
[wheezy] - sqlite3 <not-affected> (Vulnerable code introduced later)

Search for package or bug name: Reporting problems