CVE-2019-19926

NameCVE-2019-19926
DescriptionmultiSelect in select.c in SQLite 3.30.1 mishandles certain errors dur ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4638-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)stretch, stretch (security)73.0.3683.75-1~deb9u1vulnerable
buster83.0.4103.116-1~deb10u3fixed
buster (security)87.0.4280.141-0.1~deb10u1fixed
sid87.0.4280.141-0.1fixed
sqlite3 (PTS)jessie, jessie (lts)3.8.7.1-1+deb8u6fixed
stretch3.16.2-5+deb9u1fixed
stretch (security)3.16.2-5+deb9u3fixed
buster3.27.2-3+deb10u1fixed
bullseye3.34.0-1fixed
sid3.34.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsource(unstable)80.0.3987.106-1
chromiumsourcebuster80.0.3987.132-1~deb10u1DSA-4638-1
chromiumsourcestretch(unfixed)end-of-life
sqlite3source(unstable)(not affected)

Notes

- sqlite3 <not-affected> (Incomplete fix for CVE-2019-19880 not applied)
https://github.com/sqlite/sqlite/commit/8428b3b437569338a9d1e10c4cd8154acbe33089
[stretch] - chromium <end-of-life> (see DSA 4562)

Search for package or bug name: Reporting problems