CVE-2019-20916

NameCVE-2019-20916
DescriptionThe pip package before 19.2 for Python allows Directory Traversal when ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2370-1, ELA-281-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-pip (PTS)jessie, jessie (lts)1.5.6-5+deb8u1fixed
stretch9.0.1-2+deb9u1vulnerable
stretch (security)9.0.1-2+deb9u2fixed
buster18.1-5vulnerable
sid, bullseye20.1.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-pipsource(unstable)20.0.2-1
python-pipsourcejessie1.5.6-5+deb8u1ELA-281-1
python-pipsourcestretch9.0.1-2+deb9u2DLA-2370-1

Notes

[buster] - python-pip <no-dsa> (Minor issue)
https://github.com/pypa/pip/issues/6413
https://github.com/pypa/pip/commit/a4c735b14a62f9cb864533808ac63936704f2ace (19.2)

Search for package or bug name: Reporting problems