CVE-2019-25050

NameCVE-2019-25050
DescriptionnetCDF in GDAL 2.4.2 through 3.0.4 has a stack-based buffer overflow i ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gdal (PTS)jessie, jessie (lts)1.10.1+dfsg-8+deb8u2fixed
stretch2.1.2+dfsg-5fixed
buster2.4.0+dfsg-1vulnerable
bullseye3.2.2+dfsg-2fixed
bookworm, sid3.3.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gdalsourcejessie(not affected)
gdalsourcestretch(not affected)
gdalsource(unstable)3.1.0+dfsg-1

Notes

[buster] - gdal <no-dsa> (Minor issue)
[stretch] - gdal <not-affected> (Vulnerable code not present)
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/gdal/OSV-2020-420.yaml
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/gdal/OSV-2020-392.yaml
https://github.com/OSGeo/gdal/commit/767e3a56144f676ca738ef8f700e0e56035bd05a (v3.1.0RC1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15143
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15156
[jessie] - gdal <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems