CVE-2020-10756

NameCVE-2020-10756
DescriptionAn out-of-bounds read vulnerability was found in the SLiRP networking implementation of the QEMU emulator. This flaw occurs in the icmp6_send_echoreply() routine while replying to an ICMP echo request, also known as ping. This flaw allows a malicious guest to leak the contents of the host memory, resulting in possible information disclosure. This flaw affects versions of libslirp before 4.3.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2288-1, DSA-4728-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libslirp (PTS)bullseye4.4.0-1+deb11u2fixed
bookworm4.7.0-1fixed
sid, trixie4.8.0-1fixed
qemu (PTS)jessie, jessie (lts)1:2.1+dfsg-12+deb8u23fixed
stretch (security)1:2.8+dfsg-6+deb9u17fixed
stretch (lts), stretch1:2.8+dfsg-6+deb9u19fixed
buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u12fixed
bullseye1:5.2+dfsg-11+deb11u3fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm1:7.2+dfsg-7+deb12u6fixed
trixie1:8.2.4+ds-1fixed
sid1:9.0.1+ds-1fixed
slirp4netns (PTS)buster0.2.3-1vulnerable
bullseye1.0.1-2fixed
bookworm1.2.0-1fixed
sid, trixie1.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libslirpsource(unstable)4.3.1-1
qemusourcewheezy(unfixed)end-of-life
qemusourcejessie(not affected)
qemusourcestretch1:2.8+dfsg-6+deb9u10DLA-2288-1
qemusourcebuster1:3.1+dfsg-8+deb10u6DSA-4728-1
qemusource(unstable)1:4.1-2
slirp4netnssource(unstable)1.0.1-1

Notes

[buster] - slirp4netns <no-dsa> (Minor issue)
qemu 1:4.1-2 switched to system libslirp, marking that version as fixed.
slirp4netns 1.0.1-1 switched to system libslirp, marking that version as fixed.
https://bugzilla.redhat.com/show_bug.cgi?id=1835986#c11
https://github.com/rootless-containers/slirp4netns/security/advisories/GHSA-96c5-v27g-58vf
[jessie] - qemu <not-affected> (Vulnerable code introduced later)

Search for package or bug name: Reporting problems