CVE-2020-11080

NameCVE-2020-11080
DescriptionIn nghttp2 before version 1.41.0, the overly large HTTP/2 SETTINGS fra ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2786-1, DSA-4696-1, ELA-490-1
Debian Bugs962145

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nghttp2 (PTS)jessie, jessie (lts)0.6.4-2+deb8u1fixed
stretch1.18.1-1+deb9u1vulnerable
stretch (security)1.18.1-1+deb9u2fixed
buster, buster (security)1.36.0-2+deb10u1vulnerable
sid, bookworm, bullseye1.43.0-1fixed
nodejs (PTS)jessie0.10.29~dfsg-2vulnerable
stretch4.8.2~dfsg-1vulnerable
buster, buster (security)10.24.0~dfsg-1~deb10u1fixed
bullseye (security), bullseye12.22.5~dfsg-2~11u1fixed
sid, bookworm12.22.7~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nghttp2sourcejessie0.6.4-2+deb8u1ELA-490-1
nghttp2sourcestretch1.18.1-1+deb9u2DLA-2786-1
nghttp2source(unstable)1.41.0-1
nodejssourcejessie(unfixed)end-of-life
nodejssourcebuster10.21.0~dfsg-1~deb10u1DSA-4696-1
nodejssource(unstable)10.21.0~dfsg-1962145

Notes

[buster] - nghttp2 <no-dsa> (Minor issue)
[stretch] - nodejs <ignored> (Nodejs in stretch not covered by security support)
[jessie] - nodejs <end-of-life> (Nodejs in jessie not covered by security support)
https://github.com/nghttp2/nghttp2/security/advisories/GHSA-q5wr-xfw9-q7xr
https://github.com/nghttp2/nghttp2/commit/336a98feb0d56b9ac54e12736b18785c27f75090 (v1.41.0)
https://github.com/nghttp2/nghttp2/commit/f8da73bd042f810f34d19f9eae02b46d870af394 (v1.41.0)
https://nodejs.org/en/blog/vulnerability/june-2020-security-releases/#http-2-large-settings-frame-dos-low-cve-2020-11080

Search for package or bug name: Reporting problems