CVE-2020-13631

NameCVE-2020-13631
DescriptionSQLite before 3.32.0 allows a virtual table to be renamed to the name ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)jessie, jessie (lts)3.8.7.1-1+deb8u6vulnerable
stretch3.16.2-5+deb9u1fixed
stretch (security)3.16.2-5+deb9u3fixed
buster3.27.2-3+deb10u1vulnerable
bullseye3.34.0-1fixed
sid3.34.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3source(unstable)3.32.0-1
sqlite3sourcestretch(not affected)
sqlite3sourcewheezy(unfixed)end-of-life

Notes

[buster] - sqlite3 <ignored> (Minor issue, too intrusive to backport)
[stretch] - sqlite3 <not-affected> (Vulnerable code not present)
[jessie] - sqlite3 <no-dsa> (Too intrusive to backport)
https://bugs.chromium.org/p/chromium/issues/detail?id=1080459
https://sqlite.org/src/info/eca0ba2cf4c0fdf7

Search for package or bug name: Reporting problems