CVE-2020-14385

NameCVE-2020-14385
DescriptionA flaw was found in the Linux kernel before 5.9-rc4. A failure of the file system metadata validator in XFS can cause an inode with a valid, user-creatable extended attribute to be flagged as corrupt. This can lead to the filesystem being shutdown, or otherwise rendered inaccessible until it is remounted, leading to a denial of service. The highest threat from this vulnerability is to system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2385-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security)4.9.320-2fixed
stretch (lts), stretch4.9.320-3fixed
buster4.19.249-2fixed
buster (security)4.19.289-2fixed
bullseye5.10.178-3fixed
bullseye (security)5.10.191-1fixed
bookworm6.1.38-1fixed
bookworm (security)6.1.52-1fixed
sid, trixie6.5.3-1fixed
linux-4.19 (PTS)stretch (security)4.19.232-1~deb9u1fixed
stretch (lts), stretch4.19.289-2~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch(not affected)
linuxsourcebuster4.19.146-1
linuxsource(unstable)5.8.7-1
linux-4.19sourcestretch4.19.146-1~deb9u1DLA-2385-1

Notes

[stretch] - linux <not-affected> (Vulnerable code introduced later)
https://git.kernel.org/linus/f4020438fab05364018c91f7e02ebdd192085933

Search for package or bug name: Reporting problems