CVE-2020-15166

NameCVE-2020-15166
DescriptionIn ZeroMQ before version 4.3.3, there is a denial-of-service vulnerabi ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2443-1, DSA-4761-1, ELA-313-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zeromq3 (PTS)jessie, jessie (lts)4.0.5+dfsg-2+deb8u3fixed
stretch4.2.1-4+deb9u2vulnerable
stretch (security)4.2.1-4+deb9u3fixed
buster, buster (security)4.3.1-4+deb10u2fixed
sid, bullseye4.3.3-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zeromq3source(unstable)4.3.3-1
zeromq3sourcebuster4.3.1-4+deb10u2DSA-4761-1
zeromq3sourcejessie4.0.5+dfsg-2+deb8u3ELA-313-1
zeromq3sourcestretch4.2.1-4+deb9u3DLA-2443-1

Notes

https://www.openwall.com/lists/oss-security/2020/09/07/3
https://github.com/zeromq/libzmq/security/advisories/GHSA-25wp-cf8g-938m
https://github.com/zeromq/libzmq/commit/e7f0090b161ce6344f6bd35009816a925c070b09

Search for package or bug name: Reporting problems