CVE-2020-15358

NameCVE-2020-15358
DescriptionIn SQLite before 3.32.3, select.c mishandles query-flattener optimizat ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sqlite3 (PTS)jessie, jessie (lts)3.8.7.1-1+deb8u6fixed
stretch3.16.2-5+deb9u1fixed
stretch (security)3.16.2-5+deb9u3fixed
buster3.27.2-3+deb10u1fixed
sid, bullseye3.34.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sqlite3source(unstable)3.32.3-1
sqlite3sourcebuster3.27.2-3+deb10u1
sqlite3sourcejessie(not affected)
sqlite3sourcestretch(not affected)
sqlite3sourcewheezy(unfixed)end-of-life

Notes

[stretch] - sqlite3 <not-affected> (Vulnerable code introduced in 3.25.0)
[jessie] - sqlite3 <not-affected> (Vulnerable code introduced in 3.25.0)
https://www.sqlite.org/src/info/10fa79d00f8091e5
https://www.sqlite.org/src/tktview?name=8f157e8010

Search for package or bug name: Reporting problems