CVE-2020-15472

NameCVE-2020-15472
DescriptionIn nDPI through 3.2, the H.323 dissector is vulnerable to a heap-based ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs972050

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ndpi (PTS)jessie1.5.0-1vulnerable
stretch1.8-1fixed
stretch (security)1.8-1+deb9u1fixed
buster2.6-3vulnerable
bookworm, sid4.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ndpisourcejessie(unfixed)end-of-life
ndpisourcestretch(not affected)
ndpisource(unstable)3.4-1972050

Notes

[stretch] - ndpi <not-affected> (Vulnerable code introduced later)
https://github.com/ntop/nDPI/commit/b7e666e465f138ae48ab81976726e67deed12701 (3.4)

Search for package or bug name: Reporting problems