CVE-2020-15709

NameCVE-2020-15709
DescriptionVersions of add-apt-repository before 0.98.9.2, 0.96.24.32.14, 0.96.20 ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2339-1, ELA-266-1
Debian Bugs968850

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
software-properties (PTS)jessie, jessie (lts)0.92.25debian1+deb8u1fixed
stretch0.96.20.2-1vulnerable
stretch (security)0.96.20.2-1+deb9u1fixed
buster0.96.20.2-2vulnerable
sid, bullseye0.96.20.2-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
software-propertiessource(unstable)(unfixed)968850
software-propertiessourcejessie0.92.25debian1+deb8u1ELA-266-1
software-propertiessourcestretch0.96.20.2-1+deb9u1DLA-2339-1

Notes

[buster] - software-properties <no-dsa> (Minor issue)
https://www.openwall.com/lists/oss-security/2020/08/03/1
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1890286

Search for package or bug name: Reporting problems