CVE-2020-16166

NameCVE-2020-16166
DescriptionThe Linux kernel through 5.7.11 allows remote attackers to make observations that help to obtain sensitive information about the internal state of the network RNG, aka CID-f227e3ec3b5c. This is related to drivers/char/random.c and kernel/time/timer.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2385-1, DLA-2420-1, ELA-307-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security)4.9.320-2fixed
stretch (lts), stretch4.9.320-3fixed
buster4.19.249-2fixed
buster (security)4.19.289-2fixed
bullseye5.10.178-3fixed
bullseye (security)5.10.191-1fixed
bookworm6.1.38-1fixed
bookworm (security)6.1.52-1fixed
sid, trixie6.5.3-1fixed
linux-4.19 (PTS)stretch (security)4.19.232-1~deb9u1fixed
stretch (lts), stretch4.19.289-2~deb9u1fixed
linux-4.9 (PTS)jessie, jessie (lts)4.9.303-1~deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch4.9.240-1DLA-2420-1
linuxsourcebuster4.19.146-1
linuxsource(unstable)5.7.17-1
linux-4.19sourcestretch4.19.146-1~deb9u1DLA-2385-1
linux-4.9sourcejessie4.9.240-2~deb8u1ELA-307-1

Notes

https://git.kernel.org/linus/f227e3ec3b5cad859ad15666874405e8c1bbc1d4

Search for package or bug name: Reporting problems