CVE-2020-21048

NameCVE-2020-21048
DescriptionAn issue in the dither.c component of libsixel prior to v1.8.4 allows ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsixel (PTS)jessie1.1.2-1vulnerable
stretch1.5.2-2+deb9u1vulnerable
buster1.8.2-1+deb10u1vulnerable
bookworm, sid, bullseye1.8.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsixelsourcejessie(unfixed)end-of-life
libsixelsource(unstable)1.8.6-1

Notes

[buster] - libsixel <no-dsa> (Minor issue)
[stretch] - libsixel <no-dsa> (Minor issue)
https://github.com/saitoha/libsixel/issues/73
https://github.com/saitoha/libsixel/commit/cb373ab6614c910407c5e5a93ab935144e62b037 (v1.8.4)
https://github.com/saitoha/libsixel/commit/26ac06f3623279348f0dce2d191a9b6ca0c80226 (v1.8.4)

Search for package or bug name: Reporting problems