DescriptionA flaw was found in the way NSS handled CCS (ChangeCipherSpec) messages in TLS 1.3. This flaw allows a remote attacker to send multiple CCS messages, causing a denial of service for servers compiled with the NSS library. The highest threat from this vulnerability is to system availability. This flaw affects NSS versions before 3.58.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nss (PTS)jessie, jessie (lts)2:3.26-1+debu8u17vulnerable
stretch (security)2:3.26.2-1.1+deb9u5vulnerable
stretch (lts), stretch2:3.26.2-1.1+deb9u6vulnerable
buster (security)2:3.42.1-1+deb10u6vulnerable
bullseye (security), bullseye2:3.61-1+deb11u3fixed
sid, trixie2:3.92-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[buster] - nss <no-dsa> (Minor issue)
[stretch] - nss <no-dsa> (Minor issue) (private)
Fixed by:
[jessie] - nss <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems