CVE-2020-27511

NameCVE-2020-27511
DescriptionAn issue was discovered in the stripTags and unescapeHTML components i ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs991898

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
prototypejs (PTS)jessie, buster, stretch1.7.1-3vulnerable
bookworm, sid, bullseye1.7.1-3.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
prototypejssource(unstable)(unfixed)991898

Notes

[bullseye] - prototypejs <no-dsa> (Minor issue)
https://github.com/prototypejs/prototype/blame/dee2f7d8611248abce81287e1be4156011953c90/src/prototype/lang/string.js#L283
https://github.com/yetingli/PoCs/blob/main/CVE-2020-27511/Prototype.md
CVE mentions newer version but vulnerable code exists in older versions too
https://sources.debian.org/src/prototypejs/1.7.1-3/prototype-1.7.1.js/#L617
[jessie] - prototypejs <postponed> (re-check when the fix is available)

Search for package or bug name: Reporting problems