CVE-2020-36230

NameCVE-2020-36230
DescriptionA flaw was discovered in OpenLDAP before 2.4.57 leading in an assertion failure in slapd in the X.509 DN parsing in decode.c ber_next_element, resulting in denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2544-1, DSA-4845-1, ELA-358-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)jessie, jessie (lts)2.4.40+dfsg-1+deb8u11fixed
stretch (security), stretch (lts), stretch2.4.44+dfsg-5+deb9u9fixed
buster, buster (security)2.4.47+dfsg-3+deb10u7fixed
bullseye (security), bullseye2.4.57+dfsg-3+deb11u1fixed
bookworm2.5.12+dfsg-2fixed
sid2.5.13+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsourcejessie2.4.40+dfsg-1+deb8u9ELA-358-1
openldapsourcestretch2.4.44+dfsg-5+deb9u7DLA-2544-1
openldapsourcebuster2.4.47+dfsg-3+deb10u5DSA-4845-1
openldapsource(unstable)2.4.57+dfsg-1

Notes

https://bugs.openldap.org/show_bug.cgi?id=9423
https://git.openldap.org/openldap/openldap/-/commit/8c1d96ee36ed98b32cd0e28b7069c7b8ea09d793 (OPENLDAP_REL_ENG_2_4_57)

Search for package or bug name: Reporting problems