CVE-2020-36518

NameCVE-2020-36518
Descriptionjackson-databind before 2.13.0 allows a Java StackOverflow exception and denial of service via a large depth of nested objects.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2990-1, ELA-605-1
Debian Bugs1007109

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackson-databind (PTS)jessie, jessie (lts)2.4.2-2+deb8u17fixed
stretch (security), stretch (lts), stretch2.8.6-1+deb9u10fixed
buster2.9.8-3+deb10u3vulnerable
buster (security)2.9.8-3+deb10u1vulnerable
bullseye2.12.1-1vulnerable
bookworm, sid2.13.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackson-databindsourcejessie2.4.2-2+deb8u17ELA-605-1
jackson-databindsourcestretch2.8.6-1+deb9u10DLA-2990-1
jackson-databindsource(unstable)2.13.2.2-11007109

Notes

[bullseye] - jackson-databind <no-dsa> (Minor issue)
[buster] - jackson-databind <no-dsa> (Minor issue)
https://github.com/FasterXML/jackson-databind/issues/2816

Search for package or bug name: Reporting problems