CVE-2021-20300

NameCVE-2021-20300
DescriptionInteger-overflow in Imf_2_5::hufUncompress
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2732-1, ELA-469-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openexr (PTS)jessie, jessie (lts)1.6.1-8+deb8u3fixed
stretch2.2.0-11vulnerable
stretch (security)2.2.0-11+deb9u4fixed
buster, buster (security)2.2.1-4.1+deb10u1vulnerable
bullseye2.5.4-2fixed
sid, bookworm2.5.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openexrsourcejessie1.6.1-8+deb8u3ELA-469-1
openexrsourcestretch2.2.0-11+deb9u4DLA-2732-1
openexrsource(unstable)2.5.4-1

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25562
https://github.com/AcademySoftwareFoundation/openexr/commit/ed560b8a932c78d5e8e5990ce36fe7808b35d9f0 (master)
https://github.com/AcademySoftwareFoundation/openexr/commit/4212416433a230334cef0ac122cb8d722746035d (2.5.x)

Search for package or bug name: Reporting problems