CVE-2021-23437

NameCVE-2021-23437
DescriptionThe package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Ex ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)jessie, jessie (lts)2.6.1-2+deb8u6vulnerable
stretch4.0.0-4+deb9u1vulnerable
stretch (security)4.0.0-4+deb9u3vulnerable
buster5.4.1-2+deb10u2vulnerable
buster (security)5.4.1-2+deb10u1vulnerable
bullseye8.1.2+dfsg-0.3vulnerable
sid, bookworm8.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)8.3.2-1

Notes

[bullseye] - pillow <no-dsa> (Minor issue)
[buster] - pillow <no-dsa> (Minor issue)
[stretch] - pillow <postponed> (Minor issue, can be fixed in the next DLA)
https://github.com/python-pillow/Pillow/commit/9e08eb8f78fdfd2f476e1b20b7cf38683754866b
https://snyk.io/vuln/SNYK-PYTHON-PILLOW-1319443
[jessie] - pillow <postponed> (Minor issue, can be fixed in the next ELA)

Search for package or bug name: Reporting problems