CVE-2021-29505

NameCVE-2021-29505
DescriptionXStream is software for serializing Java objects to XML and back again ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2704-1, ELA-455-1
Debian Bugs989491

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxstream-java (PTS)jessie, jessie (lts)1.4.11.1-1+deb8u4fixed
stretch1.4.9-2vulnerable
stretch (security)1.4.11.1-1+deb9u4fixed
buster, buster (security)1.4.11.1-1+deb10u2vulnerable
bullseye1.4.15-3fixed
sid, bookworm1.4.18-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxstream-javasourcejessie1.4.11.1-1+deb8u3ELA-455-1
libxstream-javasourcestretch1.4.11.1-1+deb9u3DLA-2704-1
libxstream-javasource(unstable)1.4.15-3989491

Notes

https://github.com/x-stream/xstream/security/advisories/GHSA-7chv-rrw6-w6fc
https://github.com/x-stream/xstream/commit/f0c4a8d861b68ffc3119cfbbbd632deee624e227 (v1.4.17)

Search for package or bug name: Reporting problems