CVE-2021-29509

NameCVE-2021-29509
DescriptionPuma is a concurrent HTTP 1.1 server for Ruby/Rack applications. The f ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs989054

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puma (PTS)stretch3.6.0-1fixed
stretch (security)3.6.0-1+deb9u1fixed
buster3.12.0-2+deb10u2vulnerable
bookworm, bullseye4.3.8-1fixed
sid5.3.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pumasourcestretch(not affected)
pumasource(unstable)4.3.8-1989054

Notes

[stretch] - puma <not-affected> (Incomplete fix for CVE-2019-16770 not applied)
https://github.com/puma/puma/security/advisories/GHSA-q28m-8xjw-8vr5
https://github.com/puma/puma/commit/df72887170c7ef3614c941c9bdefb4a1f3546ebf
CVE is related to an incomplete fix for CVE-2019-16770

Search for package or bug name: Reporting problems