CVE-2021-31542

NameCVE-2021-31542
DescriptionIn Django 2.2 before 2.2.21, 3.1 before 3.1.9, and 3.2 before 3.2.1, M ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2651-1, ELA-421-1
Debian Bugs988053

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)jessie, jessie (lts)1.7.11-1+deb8u14fixed
stretch1:1.10.7-2+deb9u9vulnerable
stretch (security)1:1.10.7-2+deb9u14fixed
buster, buster (security)1:1.11.29-1~deb10u1vulnerable
bookworm, bullseye2:2.2.24-1fixed
sid2:3.2.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosourcejessie1.7.11-1+deb8u13ELA-421-1
python-djangosourcestretch1:1.10.7-2+deb9u13DLA-2651-1
python-djangosource(unstable)2:2.2.21-1988053

Notes

https://www.djangoproject.com/weblog/2021/may/04/security-releases/
https://github.com/django/django/commit/0b79eb36915d178aef5c6a7bbce71b1e76d376d3 (main)
https://github.com/django/django/commit/04ac1624bdc2fa737188401757cf95ced122d26d (2.2.21)

Search for package or bug name: Reporting problems