CVE-2021-31808

NameCVE-2021-31808
DescriptionAn issue was discovered in Squid before 4.15 and 5.x before 5.0.6. Due ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2685-1, DSA-4924-1, ELA-442-1
Debian Bugs989043

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster, buster (security)4.6-1+deb10u6fixed
sid, bullseye4.13-10fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u4fixed
stretch3.5.23-5+deb9u1vulnerable
stretch (security)3.5.23-5+deb9u7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsourcebuster4.6-1+deb10u6DSA-4924-1
squidsource(unstable)4.13-10989043
squid3sourcejessie3.5.23-5+deb8u4ELA-442-1
squid3sourcestretch3.5.23-5+deb9u7DLA-2685-1
squid3source(unstable)(unfixed)

Notes

https://bugzilla.suse.com/show_bug.cgi?id=1185916
https://github.com/squid-cache/squid/security/advisories/GHSA-pxwq-f3qr-w2xf
http://www.squid-cache.org/Versions/v4/changesets/squid-4-e7cf864f938f24eea8af0692c04d16790983c823.patch

Search for package or bug name: Reporting problems