CVE-2021-32272

NameCVE-2021-32272
DescriptionAn issue was discovered in faad2 before 2.10.0. A heap-buffer-overflow ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faad2 (PTS)jessie, jessie (lts)2.7-8+deb8u4fixed
stretch2.8.0~cvs20161113-1+deb9u2fixed
stretch (security)2.8.0~cvs20161113-1+deb9u3fixed
buster2.8.8-3vulnerable
bookworm, bullseye2.10.0-1fixed
sid2.10.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faad2sourcejessie(not affected)
faad2sourcestretch(not affected)
faad2source(unstable)2.10.0-1

Notes

[stretch] - faad2 <not-affected> (Vulnerable code not present, introduced in 2.8.2)
https://github.com/knik0/faad2/issues/57
https://github.com/knik0/faad2/commit/1b71a6ba963d131375f5e489b3b25e36f19f3f24 (2_10_0)
[jessie] - faad2 <not-affected> (Vulnerable code introduced in version 2.8.2)

Search for package or bug name: Reporting problems