CVE-2021-32672

NameCVE-2021-32672
DescriptionRedis is an open source, in-memory database that persists on disk. When using the Redis Lua Debugger, users can send malformed requests that cause the debugger’s protocol parser to read data beyond the actual buffer. This issue affects all versions of Redis with Lua debugging support (3.2 or newer). The problem is fixed in versions 6.2.6, 6.0.16 and 5.0.14.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2810-1, DSA-5001-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redis (PTS)jessie, jessie (lts)2:2.8.17-1+deb8u10fixed
stretch3:3.2.6-3+deb9u3vulnerable
stretch (security)3:3.2.6-3+deb9u9fixed
buster5:5.0.3-4+deb10u3vulnerable
buster (security)5:5.0.14-1+deb10u1fixed
bullseye5:6.0.15-1vulnerable
bullseye (security)5:6.0.16-1+deb11u1fixed
sid, bookworm5:6.0.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redissourcejessie(not affected)
redissourcestretch3:3.2.6-3+deb9u8DLA-2810-1
redissourcebuster5:5.0.14-1+deb10u1DSA-5001-1
redissourcebullseye5:6.0.16-1+deb11u1DSA-5001-1
redissource(unstable)5:6.0.16-1

Notes

https://github.com/redis/redis/security/advisories/GHSA-9mj9-xx53-qmxm
[jessie] - redis <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems