CVE-2021-3546

NameCVE-2021-3546
DescriptionAn out-of-bounds write vulnerability was found in the virtio vhost-user GPU device (vhost-user-gpu) of QEMU in versions up to and including 6.0. The flaw occurs while processing the 'VIRTIO_GPU_CMD_GET_CAPSET' command from the guest. It could allow a privileged guest user to crash the QEMU process on the host, resulting in a denial of service condition, or potential code execution with the privileges of the QEMU process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4980-1
Debian Bugs989042

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie, jessie (lts)1:2.1+dfsg-12+deb8u23fixed
stretch (security)1:2.8+dfsg-6+deb9u17fixed
stretch (lts), stretch1:2.8+dfsg-6+deb9u19fixed
buster (security), buster, buster (lts)1:3.1+dfsg-8+deb10u12fixed
bullseye1:5.2+dfsg-11+deb11u3fixed
bullseye (security)1:5.2+dfsg-11+deb11u2fixed
bookworm1:7.2+dfsg-7+deb12u6fixed
trixie1:8.2.4+ds-1fixed
sid1:9.0.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcejessie(not affected)
qemusourcestretch(not affected)
qemusourcebuster(not affected)
qemusourcebullseye1:5.2+dfsg-11+deb11u1DSA-4980-1
qemusource(unstable)1:6.1+dfsg-1989042

Notes

[buster] - qemu <not-affected> (Only minimal support present and not installed in binary packages)
[stretch] - qemu <not-affected> (The vulnerable code was introduced later)
https://bugzilla.redhat.com/show_bug.cgi?id=1958978
https://lists.nongnu.org/archive/html/qemu-devel/2021-05/msg01155.html
https://lists.nongnu.org/archive/html/qemu-devel/2021-05/msg01154.html
https://gitlab.com/qemu-project/qemu/-/commit/9f22893a
[jessie] - qemu <not-affected> (The vulnerable code is not present)

Search for package or bug name: Reporting problems