CVE-2021-39134

NameCVE-2021-39134
Description`@npmcli/arborist`, the library that calculates dependency trees and m ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs993407

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
npm (PTS)jessie1.4.21+ds-2vulnerable
buster5.8.0+ds6-4+deb10u2vulnerable
bullseye7.5.2+ds-2vulnerable
sid, bookworm7.24.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
npmsourceexperimental7.24.0+ds-1
npmsource(unstable)7.24.0+ds-2993407

Notes

[bullseye] - npm <no-dsa> (Minor issue)
[buster] - npm <no-dsa> (Minor issue)
https://github.com/npm/arborist/security/advisories/GHSA-2h3h-q99f-3fhc
[jessie] - npm <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems