CVE-2021-40516

NameCVE-2021-40516
DescriptionWeeChat before 3.2.1 allows remote attackers to cause a denial of serv ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2770-1, ELA-489-1
Debian Bugs993803

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
weechat (PTS)jessie, jessie (lts)1.0.1-1+deb8u4fixed
stretch1.6-1+deb9u2vulnerable
stretch (security)1.6-1+deb9u3fixed
buster2.3-1vulnerable
bullseye3.0-1vulnerable
sid, bookworm3.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
weechatsourcejessie1.0.1-1+deb8u4ELA-489-1
weechatsourcestretch1.6-1+deb9u3DLA-2770-1
weechatsource(unstable)3.2.1-1993803

Notes

[bullseye] - weechat <no-dsa> (Minor issue; can be fixed via point release)
[buster] - weechat <no-dsa> (Minor issue; can be fixed via point release)
https://github.com/weechat/weechat/commit/8b1331f98de1714bae15a9ca2e2b393ba49d735b

Search for package or bug name: Reporting problems