CVE-2021-46784

NameCVE-2021-46784
DescriptionIn Squid 3.x through 3.5.28, 4.x through 4.17, and 5.x before 5.6, due to improper buffer management, a Denial of Service can occur when processing long Gopher server responses.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5171-1, ELA-660-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster4.6-1+deb10u7fixed
buster (security)4.6-1+deb10u10fixed
bullseye (security), bullseye4.13-10+deb11u2fixed
bookworm5.7-2fixed
trixie6.6-1fixed
sid6.8-1fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u7fixed
stretch (security)3.5.23-5+deb9u7vulnerable
stretch (lts), stretch3.5.23-5+deb9u10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsourcebuster4.6-1+deb10u7DSA-5171-1
squidsourcebullseye4.13-10+deb11u1DSA-5171-1
squidsource(unstable)5.6-1
squid3sourcejessie3.5.23-5+deb8u5ELA-660-1
squid3sourcestretch3.5.23-5+deb9u8ELA-660-1
squid3source(unstable)(unfixed)

Notes

https://github.com/squid-cache/squid/security/advisories/GHSA-f5cp-6rh3-284w
https://github.com/squid-cache/squid/commit/780c4ea1b4c9d2fb41f6962aa6ed73ae57f74b2b (v4)
Squid 5: http://www.squid-cache.org/Versions/v5/changesets/SQUID-2021_7.patch
https://megamansec.github.io/Squid-Security-Audit/gopher-assert.html

Search for package or bug name: Reporting problems