CVE-2022-0319

NameCVE-2022-0319
DescriptionOut-of-bounds Read in vim/vim prior to 8.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2947-1, DLA-3182-1, ELA-576-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)jessie, jessie (lts)2:7.4.488-7+deb8u11fixed
stretch (security)2:8.0.0197-4+deb9u7fixed
stretch (lts), stretch2:8.0.0197-4+deb9u11fixed
buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u6fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm2:9.0.1378-2fixed
trixie2:9.1.0016-1fixed
sid2:9.1.0199-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcejessie2:7.4.488-7+deb8u5ELA-576-1
vimsourcestretch2:8.0.0197-4+deb9u5DLA-2947-1
vimsourcebuster2:8.1.0875-5+deb10u3DLA-3182-1
vimsource(unstable)2:8.2.4659-1unimportant

Notes

https://huntr.dev/bounties/ba622fd2-e6ef-4ad9-95b4-17f87b68755b
https://github.com/vim/vim/commit/05b27615481e72e3b338bb12990fb3e0c2ecc2a9 (v8.2.4154)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems