CVE-2022-0487

NameCVE-2022-0487
DescriptionA use-after-free vulnerability was found in rtsx_usb_ms_drv_remove in drivers/memstick/host/rtsx_usb_ms.c in memstick in the Linux kernel. In this flaw, a local attacker with a user privilege may impact system Confidentiality. This flaw affects kernel versions prior to 5.14 rc1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2940-1, DLA-2941-1, DSA-5095-1, DSA-5096-1, ELA-577-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security)4.9.320-2fixed
stretch (lts), stretch4.9.320-3fixed
buster4.19.249-2fixed
buster (security)4.19.304-1fixed
bullseye5.10.209-2fixed
bullseye (security)5.10.205-2fixed
bookworm6.1.76-1fixed
bookworm (security)6.1.85-1fixed
trixie6.6.15-2fixed
sid6.7.9-2fixed
linux-4.19 (PTS)stretch (security)4.19.232-1~deb9u1fixed
stretch (lts), stretch4.19.304-1~deb9u1fixed
linux-4.9 (PTS)jessie, jessie (lts)4.9.303-1~deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch4.9.303-1DLA-2940-1
linuxsourcebuster4.19.232-1DSA-5096-1
linuxsourcebullseye5.10.103-1DSA-5095-1
linuxsource(unstable)5.16.10-1unimportant
linux-4.19sourcestretch4.19.232-1~deb9u1DLA-2941-1
linux-4.9sourcejessie4.9.303-1~deb8u1ELA-577-1

Notes

https://bugzilla.suse.com/show_bug.cgi?id=1194516
https://lore.kernel.org/all/20220114075934.302464-1-gregkh@linuxfoundation.org/
https://git.kernel.org/linus/bd2db32e7c3e35bd4d9b8bbff689434a50893546 (5.17-rc4)
CONFIG_MMC_MOXART is not set in Debian.

Search for package or bug name: Reporting problems