CVE-2022-1184

NameCVE-2022-1184
DescriptionA use-after-free flaw was found in fs/ext4/namei.c:dx_insert_block() in the Linux kernel’s filesystem sub-component. This flaw allows a local attacker with a user privilege to cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3173-1, DSA-5257-1, ELA-652-1, ELA-723-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security)4.9.320-2vulnerable
stretch (lts), stretch4.9.320-3vulnerable
buster4.19.249-2vulnerable
buster (security)4.19.269-1vulnerable
bullseye5.10.158-2fixed
bullseye (security)5.10.162-1fixed
bookworm6.1.4-1fixed
sid6.1.7-1fixed
linux-4.19 (PTS)jessie, jessie (lts)4.19.269-1~deb8u1fixed
stretch (security)4.19.232-1~deb9u1vulnerable
stretch (lts), stretch4.19.269-1~deb9u1fixed
linux-5.10 (PTS)stretch (lts), stretch5.10.158-2~deb9u1fixed
buster (security)5.10.158-2~deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch(unfixed)end-of-life
linuxsourcebullseye5.10.149-1DSA-5257-1
linuxsource(unstable)5.19.6-1
linux-4.19sourcejessie4.19.249-2~deb8u1ELA-652-1
linux-4.19sourcestretch4.19.249-2~deb9u1ELA-652-1
linux-5.10sourcestretch5.10.149-2~deb9u1ELA-723-1
linux-5.10sourcebuster5.10.149-2~deb10u1DLA-3173-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=2070205
https://git.kernel.org/linus/65f8ea4cd57dbd46ea13b41dc8bac03176b04233

Search for package or bug name: Reporting problems