CVE-2022-1328

NameCVE-2022-1328
DescriptionBuffer Overflow in uudecoder in Mutt affecting all versions starting from 0.94.13 before 2.2.3 allows read past end of input line
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2999-1, ELA-607-1
Debian Bugs1009734, 1009735

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mutt (PTS)jessie, jessie (lts)1.5.23-3+deb8u6fixed
stretch (security), stretch (lts), stretch1.7.2-1+deb9u6fixed
buster, buster (security)1.10.1-2.1+deb10u5vulnerable
bullseye2.0.5-4.1vulnerable
bookworm, sid2.2.4-1fixed
neomutt (PTS)buster20180716+dfsg.1-1+deb10u2vulnerable
buster (security)20180716+dfsg.1-1+deb10u1vulnerable
bullseye20201127+dfsg.1-1.2vulnerable
bookworm, sid20211029+dfsg1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
muttsourcejessie1.5.23-3+deb8u6ELA-607-1
muttsourcestretch1.7.2-1+deb9u6DLA-2999-1
muttsource(unstable)2.2.3-11009734
neomuttsource(unstable)(unfixed)1009735

Notes

[bullseye] - mutt <no-dsa> (Minor issue)
[buster] - mutt <no-dsa> (Minor issue)
[bullseye] - neomutt <no-dsa> (Minor issue)
[buster] - neomutt <no-dsa> (Minor issue)
https://gitlab.com/muttmua/mutt/-/issues/404
https://gitlab.com/muttmua/mutt/-/commit/e5ed080c00e59701ca62ef9b2a6d2612ebf765a5
https://gitlab.com/neomutt/neomutt/-/commit/ee7cb4e461c1cdf0ac14817b03687d5908b85f84

Search for package or bug name: Reporting problems