CVE-2022-22747

NameCVE-2022-22747
DescriptionAfter accepting an untrusted certificate, handling an empty pkcs7 sequence as part of the certificate data could have lead to a crash. This crash is believed to be unexploitable. This vulnerability affects Firefox ESR < 91.5, Firefox < 96, and Thunderbird < 91.5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2880-1, DLA-2881-1, DLA-2898-1, DSA-5044-1, DSA-5045-1, DSA-5062-1, ELA-550-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid124.0.1-1fixed
firefox-esr (PTS)jessie, jessie (lts)68.9.0esr-1~deb8u2vulnerable
stretch (security), stretch (lts), stretch91.11.0esr-1~deb9u1fixed
buster91.12.0esr-1~deb10u1fixed
buster (security)115.9.1esr-1~deb10u1fixed
bullseye115.7.0esr-1~deb11u1fixed
bullseye (security)115.9.1esr-1~deb11u1fixed
bookworm115.7.0esr-1~deb12u1fixed
bookworm (security)115.9.1esr-1~deb12u1fixed
trixie115.8.0esr-1fixed
sid115.9.1esr-1fixed
nss (PTS)jessie, jessie (lts)2:3.26-1+debu8u18fixed
stretch (security)2:3.26.2-1.1+deb9u5fixed
stretch (lts), stretch2:3.26.2-1.1+deb9u7fixed
buster2:3.42.1-1+deb10u5fixed
buster (security)2:3.42.1-1+deb10u8fixed
bullseye (security), bullseye2:3.61-1+deb11u3fixed
bookworm2:3.87.1-1fixed
trixie, sid2:3.99-1fixed
thunderbird (PTS)jessie, jessie (lts)1:68.9.0-1~deb8u2vulnerable
stretch (security), stretch (lts), stretch1:91.10.0-1~deb9u1fixed
buster1:91.12.0-1~deb10u1fixed
buster (security)1:115.9.0-1~deb10u1fixed
bullseye1:115.7.0-1~deb11u1fixed
bullseye (security)1:115.9.0-1~deb11u1fixed
bookworm1:115.7.0-1~deb12u1fixed
bookworm (security)1:115.9.0-1~deb12u1fixed
sid1:115.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)96.0-1
firefox-esrsourcejessie(unfixed)end-of-life
firefox-esrsourcestretch91.5.0esr-1~deb9u1DLA-2880-1
firefox-esrsourcebuster91.5.0esr-1~deb10u1DSA-5044-1
firefox-esrsourcebullseye91.5.0esr-1~deb11u1DSA-5044-1
firefox-esrsource(unstable)91.5.0esr-1
nsssourcejessie2:3.26-1+debu8u16ELA-550-1
nsssourcestretch2:3.26.2-1.1+deb9u5DLA-2898-1
nsssourcebuster2:3.42.1-1+deb10u5DSA-5062-1
nsssourcebullseye2:3.61-1+deb11u2DSA-5062-1
nsssource(unstable)2:3.73-1
thunderbirdsourcejessie(unfixed)end-of-life
thunderbirdsourcestretch1:91.5.0-1~deb9u1DLA-2881-1
thunderbirdsourcebuster1:91.5.0-2~deb10u1DSA-5045-1
thunderbirdsourcebullseye1:91.5.0-2~deb11u1DSA-5045-1
thunderbirdsource(unstable)1:91.5.0-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2022-01/#CVE-2022-22747
https://www.mozilla.org/en-US/security/advisories/mfsa2022-02/#CVE-2022-22747
https://www.mozilla.org/en-US/security/advisories/mfsa2022-03/#CVE-2022-22747
https://bugzilla.mozilla.org/show_bug.cgi?id=1735028
https://hg.mozilla.org/projects/nss/rev/7ff99e71f3e37faed12bc3cc90a3eed27e3418d0

Search for package or bug name: Reporting problems