CVE-2022-2288

NameCVE-2022-2288
DescriptionOut-of-bounds Write in GitHub repository vim/vim prior to 9.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1015984

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)jessie, jessie (lts)2:7.4.488-7+deb8u11fixed
stretch (security)2:8.0.0197-4+deb9u7fixed
stretch (lts), stretch2:8.0.0197-4+deb9u11fixed
buster2:8.1.0875-5+deb10u2fixed
buster (security)2:8.1.0875-5+deb10u6fixed
bullseye2:8.2.2434-3+deb11u1fixed
bookworm2:9.0.1378-2fixed
trixie2:9.1.0016-1fixed
sid2:9.1.0199-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcejessie(not affected)
vimsourcestretch(not affected)
vimsourcebuster(not affected)
vimsourcebullseye(not affected)
vimsource(unstable)2:9.0.0135-11015984

Notes

[bullseye] - vim <not-affected> (vulnerable code introduced in 8.2.4763)
[buster] - vim <not-affected> (vulnerable code introduced in 8.2.4763)
https://huntr.dev/bounties/a71bdcb7-4e9b-4650-ab6a-fe8e3e9852ad/
https://github.com/vim/vim/commit/c6fdb15d423df22e1776844811d082322475e48a (v9.0.0025)
[stretch] - vim <not-affected> (vulnerable code introduced in 8.2.4763)
[jessie] - vim <not-affected> (vulnerable code introduced in 8.2.4763)

Search for package or bug name: Reporting problems