CVE-2022-23303

NameCVE-2022-23303
DescriptionThe implementations of SAE in hostapd before 2.10 and wpa_supplicant before 2.10 are vulnerable to side channel attacks as a result of cache access patterns. NOTE: this issue exists because of an incomplete fix for CVE-2019-9494.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie, jessie (lts)2.3-1+deb8u13fixed
stretch (security), stretch (lts), stretch2:2.4-1+deb9u9fixed
buster2:2.7+git20190128+0c1e29f-6+deb10u3vulnerable
buster (security)2:2.7+git20190128+0c1e29f-6+deb10u4vulnerable
bullseye2:2.9.0-21vulnerable
bookworm2:2.10-12fixed
sid, trixie2:2.10-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasourcejessie(not affected)
wpasourcestretch(not affected)
wpasource(unstable)2:2.10-1

Notes

[bullseye] - wpa <no-dsa> (Minor issue)
[buster] - wpa <no-dsa> (Minor issue)
[stretch] - wpa <not-affected> (CVE-2019-9494 was not applied and is marked as ignored)
https://w1.fi/security/2022-1/
Issue exists because of an incomplete fix for CVE-2019-9494
[jessie] - wpa <not-affected> (CVE-2019-9494 was not applied)

Search for package or bug name: Reporting problems