CVE-2022-3028

NameCVE-2022-3028
DescriptionA race condition was found in the Linux kernel's IP framework for transforming packets (XFRM subsystem) when multiple calls to xfrm_probe_algs occurred simultaneously. This flaw could allow a local attacker to potentially trigger an out-of-bounds write or leak kernel heap memory by performing an out-of-bounds read and copying it into a socket.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3131-1, DLA-3173-1, ELA-696-1, ELA-723-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security)4.9.320-2vulnerable
stretch (lts), stretch4.9.320-3vulnerable
buster4.19.249-2vulnerable
buster (security)4.19.304-1fixed
bullseye5.10.209-2fixed
bullseye (security)5.10.205-2fixed
bookworm6.1.76-1fixed
bookworm (security)6.1.69-1fixed
trixie6.6.15-2fixed
sid6.7.7-1fixed
linux-4.19 (PTS)jessie, jessie (lts)4.19.304-1~deb8u1fixed
stretch (security)4.19.232-1~deb9u1vulnerable
stretch (lts), stretch4.19.304-1~deb9u1fixed
linux-5.10 (PTS)stretch (lts), stretch5.10.205-2~deb9u1fixed
buster (security)5.10.209-2~deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch(unfixed)end-of-life
linuxsourcebuster4.19.260-1DLA-3131-1
linuxsourcebullseye5.10.140-1
linuxsource(unstable)5.19.6-1
linux-4.19sourcejessie4.19.260-1~deb8u1ELA-696-1
linux-4.19sourcestretch4.19.260-1~deb9u1ELA-696-1
linux-5.10sourcestretch5.10.149-2~deb9u1ELA-723-1
linux-5.10sourcebuster5.10.149-2~deb10u1DLA-3173-1

Notes

https://lore.kernel.org/all/YtoWqEkKzvimzWS5@gondor.apana.org.au/T/
https://git.kernel.org/linus/ba953a9d89a00c078b85f4b190bc1dde66fe16b5 (6.0-rc3)

Search for package or bug name: Reporting problems