CVE-2022-3037

NameCVE-2022-3037
DescriptionUse After Free in GitHub repository vim/vim prior to 9.0.0322.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1019590

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)jessie, jessie (lts)2:7.4.488-7+deb8u11fixed
stretch (security)2:8.0.0197-4+deb9u7fixed
stretch (lts), stretch2:8.0.0197-4+deb9u11fixed
buster2:8.1.0875-5+deb10u2fixed
buster (security)2:8.1.0875-5+deb10u6fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm2:9.0.1378-2fixed
trixie2:9.1.0016-1fixed
sid2:9.1.0199-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcejessie(not affected)
vimsourcestretch(not affected)
vimsourcebuster(not affected)
vimsource(unstable)2:9.0.0626-1unimportant1019590

Notes

[buster] - vim <not-affected> (quickfixtextfunc added in 8.2.0869)
https://huntr.dev/bounties/af4c2f2d-d754-4607-b565-9e92f3f717b5
https://github.com/vim/vim/commit/4f1b083be43f351bc107541e7b0c9655a5d2c0bb (v9.0.0322)
Crash in CLI tool, no security impact
[stretch] - vim <not-affected> (quickfixtextfunc added in 8.2.0869)
[jessie] - vim <not-affected> (quickfixtextfunc added in 8.2.0869)

Search for package or bug name: Reporting problems