CVE-2022-30594

NameCVE-2022-30594
DescriptionThe Linux kernel before 5.17.2 mishandles seccomp permissions. The PTRACE_SEIZE code path allows attackers to bypass intended restrictions on setting the PT_SUSPEND_SECCOMP flag.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3065-1, DSA-5173-1, ELA-652-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security), stretch (lts), stretch4.9.320-2fixed
buster, buster (security)4.19.249-2fixed
bullseye5.10.140-1fixed
bullseye (security)5.10.136-1fixed
sid, bookworm5.19.6-1fixed
linux-4.19 (PTS)jessie, jessie (lts)4.19.249-2~deb8u1fixed
stretch (security)4.19.232-1~deb9u1vulnerable
stretch (lts), stretch4.19.249-2~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch4.9.320-2DLA-3065-1
linuxsourcebuster4.19.249-2DSA-5173-1
linuxsourcebullseye5.10.113-1
linuxsource(unstable)5.17.3-1
linux-4.19sourcejessie4.19.249-2~deb8u1ELA-652-1
linux-4.19sourcestretch4.19.249-2~deb9u1ELA-652-1

Notes

https://bugs.chromium.org/p/project-zero/issues/detail?id=2276
https://git.kernel.org/linus/ee1fee900537b5d9560e9f937402de5ddc8412f3 (5.18-rc1)

Search for package or bug name: Reporting problems