CVE-2022-3234

NameCVE-2022-3234
DescriptionHeap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0483.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3182-1, ELA-733-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)jessie, jessie (lts)2:7.4.488-7+deb8u11fixed
stretch (security)2:8.0.0197-4+deb9u7vulnerable
stretch (lts), stretch2:8.0.0197-4+deb9u11fixed
buster2:8.1.0875-5+deb10u2vulnerable
buster (security)2:8.1.0875-5+deb10u6fixed
bullseye2:8.2.2434-3+deb11u1vulnerable
bookworm2:9.0.1378-2fixed
trixie2:9.1.0016-1fixed
sid2:9.1.0199-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourcejessie2:7.4.488-7+deb8u8ELA-733-1
vimsourcestretch2:8.0.0197-4+deb9u8ELA-733-1
vimsourcebuster2:8.1.0875-5+deb10u3DLA-3182-1
vimsource(unstable)2:9.0.0626-1unimportant

Notes

https://huntr.dev/bounties/90fdf374-bf04-4386-8a23-38c83b88f0da/
https://github.com/vim/vim/commit/c249913edc35c0e666d783bfc21595cf9f7d9e0d (v9.0.0483)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems