CVE-2022-33981

NameCVE-2022-33981
Descriptiondrivers/block/floppy.c in the Linux kernel before 5.17.6 is vulnerable to a denial of service, because of a concurrency use-after-free flaw after deallocating raw_cmd in the raw_cmd_ioctl function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3065-1, DSA-5173-1, ELA-652-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security), stretch (lts), stretch4.9.320-2fixed
buster, buster (security)4.19.249-2fixed
bullseye5.10.140-1fixed
bullseye (security)5.10.136-1fixed
sid, bookworm5.19.6-1fixed
linux-4.19 (PTS)jessie, jessie (lts)4.19.249-2~deb8u1fixed
stretch (security)4.19.232-1~deb9u1vulnerable
stretch (lts), stretch4.19.249-2~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch4.9.320-2DLA-3065-1
linuxsourcebuster4.19.249-2DSA-5173-1
linuxsourcebullseye5.10.113-1
linuxsource(unstable)5.17.6-1
linux-4.19sourcejessie4.19.249-2~deb8u1ELA-652-1
linux-4.19sourcestretch4.19.249-2~deb9u1ELA-652-1

Notes

https://www.openwall.com/lists/oss-security/2022/04/28/1
https://git.kernel.org/linus/233087ca063686964a53c829d547c7571e3f67bf (5.18-rc5)

Search for package or bug name: Reporting problems