CVE-2022-35414

NameCVE-2022-35414
Descriptionsoftmmu/physmem.c in QEMU through 7.0.0 can perform an uninitialized read on the translate_fail path, leading to an io_readx or io_writex crash. NOTE: a third party states that the Non-virtualization Use Case in the qemu.org reference applies here, i.e., "Bugs affecting the non-virtualization use case are not considered security bugs at this time.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3099-1
Debian Bugs1014958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie, jessie (lts)1:2.1+dfsg-12+deb8u23vulnerable
stretch (security)1:2.8+dfsg-6+deb9u17vulnerable
stretch (lts), stretch1:2.8+dfsg-6+deb9u19vulnerable
buster1:3.1+dfsg-8+deb10u8vulnerable
buster (security)1:3.1+dfsg-8+deb10u12fixed
bullseye1:5.2+dfsg-11+deb11u3vulnerable
bullseye (security)1:5.2+dfsg-11+deb11u2vulnerable
bookworm1:7.2+dfsg-7+deb12u6fixed
trixie1:8.2.4+ds-1fixed
sid1:9.0.2+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcebuster1:3.1+dfsg-8+deb10u9DLA-3099-1
qemusource(unstable)1:7.1+dfsg-1unimportant1014958

Notes

https://gitlab.com/qemu-project/qemu/-/issues/1065
https://github.com/qemu/qemu/commit/418ade7849ce7641c0f7333718caf5091a02fd4c (v7.1.0-rc0)
https://sick.codes/sick-2022-113
Not deemed a security issue per https://www.qemu.org/docs/master/system/security.html#security-requirements

Search for package or bug name: Reporting problems