CVE-2022-3996

NameCVE-2022-3996
DescriptionIf an X.509 certificate contains a malformed policy constraint and policy processing is enabled, then a write lock will be taken twice recursively. On some operating systems (most widely: Windows) this results in a denial of service when the affected process hangs. Policy processing being enabled on a publicly facing server is not considered to be a common setup. Policy processing is enabled by passing the `-policy' argument to the command line utilities or by calling the `X509_VERIFY_PARAM_set1_policies()' function. Update (31 March 2023): The description of the policy processing enablement was corrected based on CVE-2023-0466.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1027102

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)jessie, jessie (lts)1.0.1t-1+deb8u21fixed
stretch (security)1.1.0l-1~deb9u6fixed
stretch (lts), stretch1.1.0l-1~deb9u9fixed
buster1.1.1n-0+deb10u3fixed
buster (security)1.1.1n-0+deb10u6fixed
bullseye1.1.1w-0+deb11u1fixed
bullseye (security)1.1.1n-0+deb11u5fixed
bookworm (security), bookworm3.0.11-1~deb12u2fixed
trixie3.1.5-1fixed
sid3.1.5-1.1fixed
openssl1.0 (PTS)stretch (security)1.0.2u-1~deb9u7fixed
stretch (lts), stretch1.0.2u-1~deb9u9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsourcejessie(not affected)
opensslsourcestretch(not affected)
opensslsourcebuster(not affected)
opensslsourcebullseye(not affected)
opensslsource(unstable)3.0.7-21027102
openssl1.0source(unstable)(not affected)

Notes

[bullseye] - openssl <not-affected> (Only affects 3.0.x)
[buster] - openssl <not-affected> (Only affects 3.0.x)
https://www.openssl.org/news/secadv/20221213.txt
https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=7725e7bfe6f2ce8146b6552b44e0d226be7638e7
[stretch] - openssl <not-affected> (Only affects 3.0.x)
[jessie] - openssl <not-affected> (Only affects 3.0.x)
- openssl1.0 <not-affected> (Only affects 3.0.x)

Search for package or bug name: Reporting problems